LifterLMS Stripe Add-On Releases SCA Compatibility in New Version

LifterLMS Stripe 5.0 just rolled out to the public adding Strong Customer Authentication (SCA) compatibility.

If you sell online courses or memberships with LifterLMS via Stripe to people who are buying from Europe, you need to update to LifterLMS Stripe 5.0 so that you can continue to make sales in the EU on September 14 and beyond.

Basically, European banks are requiring an extra layer of security when people make purchases online. Stripe and LifterLMS have accommodated this new requirement.

What is Strong Customer Compliance?

Strong Customer Authentication (SCA) is a new European regulatory requirement to reduce fraud and make online payments more secure. 

On 14 September 2019, new requirements for authenticating online payments will be introduced in Europe as part of the second Payment Services Directive (PSD2)

Learn more about Stripe and Strong Customer Authentication here.

Here’s What I’d Like You To Do Next …

Update to the latest version of the LifterLMS Stripe add-on before September 14.

That’s it. Enjoy the new benefits and continued sales success in the European Union!

STOP! Don’t let the requirements of building your online course website slow you down

Our course organizer will help you get your course out of your head and onto the web.

Free Instant Download

Leave a Comment

Your email address will not be published. Required fields are marked *